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Create A Spinning Logo Tutorial. ©Bob Taylor 2009

To do this you will need two programs from Xara: Xara Xtreme (or Xtreme Pro) and Xara 3D
They are available from: http://www.xara.com. Xtreme is available as a fully functional time-limited
free trial. Xara 3D is also fully functional, but the trial version will have a background watermark

behind your work that can only be removed by purchasing the program.
The most popular request at Talkgraphics.com is for assistance in making a spinning logo. The members are
more than willing to guide you through the process, but they will not do the work for you for free.

Useful Information

We are going to use a shield shape with a graphic behind it as a background. If you already have a graphic that you want to use, then if it is a vector
graphic it can be imported into Xtreme. If this is the case, then it will make your job pretty straightforward.

More often than not, though you will be using a bitmap image (.bmp .jpg .png etc.) which is made up of pixels.They are also known as raster images.
You can spot a bitmap/raster image by zooming in and you will find that the graphic becomes “blocky” or pixellated (Fig.A). A vector graphic will
stay clear and sharp even at maximum zoom level, and using a vector application like Xara Xtreme, can often be ungrouped and pulled apart

too. (Fig.B). Often bitmaps have a white background and you need to find a way to remove this background and convert the image into a vector
shape, which Xara 3D can work with. Fig. A Fig. B
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Preparation Using Xara Xtreme
Using Xara Xtreme, import your bitmap. try to find the highest resolution (quality) available.With your bitmap on the workspace, zoom in close
enough to see it clearly and using either the Shape Editor Tool (Fig. |) or the Pen Tool (Fig. 2), (most seem to find the Shape Editor easier to use)
trace around the shield. I'm using the Shape Editor in my screenshots. Start at the top left corner and with your tool selected, click and hold down
the Control Key to constrain the line horizontally and clich again on the top right hand corner, and your first straight line has been created (Fig. 3).
Keeping the line and the Shape Editor selected, click vertically down the side of the shield at the point where the line starts to curve .Then click
again on the opposite side of the shield, and then vertically up to the point where you started. As you do this, you will see a“+” sign appear on
the cursor and when the shape has completed, it will fill with colour (default is black) (Fig. 4).

—l Fig. 4




Preparation Using Xara Xtreme

Fig.5 At this point, with the filled shape selected, you may want to click on the mesh filled square at the bottom left of the workspace (Fig. 5) which will
[€] # ] set the shape to “no fill” and will allow you to see what you are doing more easily.
l With the now unfilled shape still selected, using the Shape Editor Tool, point the cursor at the bottom of the shape in the centre of the shield (Fig. 6)

and drag the line down to the very edge of the curve of the shield (Fig. 7).You will see I've circled the 2 drag handles at the bottom of Fig. 7.
These handles are selectable with the Shape Editor Tool, to enable you to drag them into a position so that they match up with the outline of the
curve of the shield. Note the position of the handles in Fig. 8 which will give you an idea of where to position yours. The red dotted guideline is to
point out that both the handles are in the same position relative to both sides of the shield. Fig. 6 Fig. 7 Fig. 8
You may be pleased to know that you have finished with the Shape Editor Tool! e
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Fig. 9 Now select the Selector Tool (Fig. 9) and click and drag around the whole of the shape you
| LS have just drawn, including the rest of the bitmap. Now go to the Arrange Menu and select

“Combine Shapes” and then “Intersect Shapes”. or press Ctrl + 3 on the keyboard.
You now have the vector shape that will be used in Xara 3D.

o o
Just 2 more things to do.

|. Select the vector shape you have just drawn and go to the File Menu and Choose export. In the dialogue box that opens (Fig. 10) choose PNG and
click on the “Export” button.

: Fig. 10
The Export Dialoge Box (Fig. | 1) will - =
open and on the Palette Options Tab '!;)g Hleniais: i V] Export
choose “True Colour + Alpha” Gt , ——
and on the Bitmap Size Tab choose SENE s e 1% [ L ] [ Sl J

300 DPI and click on the “Export” button.

12. Select your vector shield shape again, and copy it to the

Image A (100% SELECTED —— |PNG [ Image B [100%) —  clipboard (Ctrl +C).
@ You are now ready to open Xara 3D and move on to the
next part of the tutorial.
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Working on your Spining Logo With Xara 3D

Having copied the vector shield to the clipboard, you now have to open Xara 3D.When it loads you will see this (Fig. 12):
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You will need to clear your workspace. Go to the Edit Menu and choose Select All (Ctrl + A) and then press the Delete key on the keyboard.The
result can be seen in Fig. |3. Next, under the Options Menu you will see the Show/Hide Cursor Icon, (Fig. |4)—>Qptions Click it to remove

\a_lb\ B the cursor.

Next, click the Text lcon in the left hand toolbar (Fig. I5).—Or x ’ Your workspace should now be empty.

Go to the Edit Menu and choose “Paste” (Ctrl + V). If your vector shield is still on the clipboard, you will see a blank shape appear in your
workspace (Fig. 16). Now go to the texture options in Xara 3D (Fig.17) and load the .png file that you cut out and exported from Xara Xtreme
as a texture. Make sure the Texture Checkbox is ticked and that Text is in the drop-down box. Now click on the “Load Texture” button.

This brings up a dialogue box that allows you to navigate to where you saved the .png file of the shield you cut out and exported from

Xara Xtreme. Click on the “Load Texture” button and your result should be similar to mine (Fig. 18). Adjustments to this coming up next.

Fig. 16 Fig. 17 Fig. 18
- Texture options
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Working on your Spining Logo With Xara 3D (Continued)

Fig. 18 (again)

- Obviously we are not finished yet, we need to look at the tool options on the right-hand side of the Xara 3D
workspace.You may have to adjust the sliders to the left of the Load Texture Button (Fig.19) to get a perfect
fit onto your shield. The Size slider would be a good place to start. Increase or decrease the values with the
texture scaling slider that pops out when you click on the black triangles.

Remember you can undo (Ctrl + Z) at any stage to go back to a point that you prefer.

] Fig.19
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Later we’ll have a look at all the other options on the right hand tool box for adjusting shadow, bevels, extrusion and animation etcetera.
But first we’ll have a look at the Lighting Options. Fig. 20 Fig. 21

Options Window | Options Window |
Lighting Options o | Hy|[(@)f%(m). k) B9 =)

Below the Window Menu, click on the Lightbulb Icon (Fig.20 above) and you'll see three coloured arrows appear. These control the position (click + drag)
of the lights and their colour (double click an arrow to adjust). If you click and drag on the shield you can manualy drag it so that it faces face on rather
than at an angle to the left as we look at the screen. Below in Fig. 22 you will see how | have positioned my lights and which colours | have used.

Fig. 22 At this point we can have a look at how the animation looks with these lighting settings. Under the Options menu
you will see a Movie Strip Icon with a green triangle at the side (Fig 2| above). Click on this icon and your shield will

Shadow confrol W/ spin! The default setting is as shown in the Animation Options shown below in Fig. 23.
"i‘l\ An imation OPtiOﬂS Animation options
&:’ Back to the Options on the right-hand side of the X3D workspace. Frames per cycle : 40
< As it happens, the default Animation Options settings suit my purposes for Fiamics deisacand | 15 Pause : | Do
this tutorial. But they can be adjusted to suit your requirements. :
Experiment with all the settings to see what they do. [ Loop: . :
We will return to the Animation Options later when we talk about exporting | Spie : Fotate 1 |;| [Egp.nimaﬁon picker]

your masterpiece.The next step will be the Shadow Options.

Apply to

Shadow Options @ Text:

When we were looking at the Animation Options, you may have noticed another arrow in various shades of black Broil Pans _

and white (Fig. 22 above). For those of you who know Xara Xtreme, this works in the same way and the arrow only [Lights: <o -
alters the position of the shadow. Shadow options ]

The Shadow Options dialogue is very straightforward as you can see from Fig. 24 >

Shadaw Transparency : | 75% @
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Working on your Spining Logo With Xara 3D (Continued) | Fig. 25

Extrusion Options

In the Extrusion Options dialogue box (Fig. 25) | have altered the default settings shown in Fig.|8 and used the
settings shown.The results can be seen in Fig.26.Again, little explanation required, as the Extrusion Depth control

slider works exactly the same as the Texture Options dialogue (Fig. 19).

Bevel Options

The Bevel Options dialogue box (Fig.27) allows you to determine how the edges of your shield will look.
There are many choices available for the type of bevel that can be applied. If the extrusion depth is

increased (Fig.25 above) then the bevel shape will be more pronounced.The same is true of the Bevel Depth,

Miter and Round options.The settings in Fig.27 are displayed in the example shown (Fig.28).

Colour Options

The Colour Options dialogue box (Fig. 29) may be used to precisely alter the colours of all the
elements of the X3D workspace. As you can see here, it can change the colours of Text, Text faces,
Text sides, all three lights and the shadow.A different screenshot of the same dialogue box (Fig.30)
shows more clearly the two colour swatches.The narrow rectangle is used to select a particular part
of the spectrum from re, to orange, yellow, green, blue, magenta, to red again.
Once you are in the general area of the colour you want, the larger rectangle helps you choose the

shade of the colour you want.

One area of the Colour Options dialogue box not covered here, the Texture Checkbox, will be examined
in the next step: Placing A Background Behind Your Logo & Exporting Your Work.
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Placing A Background Behind Your Logo & Exporting Your Work.

To place your intended background into X3D you need to go to the Colour Options Menu (Fig. 3 1).

Make sure the drop-down menu shows “Background” and that the Texture Tickbox is checked.

A dialogue box will open which will ask you to navigate to the file you want to use.

Click “Open” and the background will load. The way it will look depends on the file size, and may be either too large to fit,
or too small so that the graphic will repeat vertically as well as horizontally. You can import the graphic into Xara Xtreme and
resize it using the export dialogue, which will require some trial and error.

The background in X3D may be clicked and dragged so that you can position it how you want.

The next stage is exporting your animation in the format of your choice.

My finished result may be seen below (static) in Fig.35 and online at:
File name:

Save as type: AV *.avi)

Fig. 31
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Fig. 32

Save

Cancel

AV *avi)
Animated cursors (*.ani)
Flash bitmap [*.swf)

Flash vector (*.swf}

Go to the File Menu and select “Export animation...” From the dialogue box (Fig. 32) you can
choose how and where you want to export it (gif is the one which displays the animation on a

web page). When you click on the “Save” button, the dialogue box (Fig.33) opens.
If you are exporting with the background included, make sure the “Transparent” Tickbox is unchecked.

The Width and Height boxes will determine how much of the chosen background is displayed and may have to : Fig. 33 ;
be adjusted to suit your exported file. You may have to save and re-export a few times until you are satisfied with the result. X
The other important factor is the file size, especially for the web. The less colours you use, the window size and the Siee Palete
Animation Options (Fig. 34) on the right hand toolbar, will all have a bearing on the size of your exported file. Eﬁjgfz‘em:?“'ze ] Oiimised
Reducing the frames per cycle and frames per second values will reduce the file size accordingly. But there is a trade-off o P = FiPurians
between these values, and also the colour values in the Export dialogue box. —_— o
The lower the values will give a lower file size and also a poorer quality result.  Ofbodr  OBboo I:A|1"rAansparent
Examples below show the difference when importing your background texture at 96 dpi (Fig.35) and 300 dpi (Fig 36) O32cdor @ 266 cokor
Experimentation is the answer and will stand you in good stead for any future work with Xara 3D. EL”N!:; bt C
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